您的位置:首页 > 其它

hduoj1060(Leftmost Digit)

2015-03-06 16:29 183 查看

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 14145 Accepted Submission(s): 5413 [align=left]Problem Description[/align]Given a positive integer N, you should output the leftmost digit of N^N. [align=left]Input[/align]The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains a single positive integer N(1<=N<=1,000,000,000). [align=left]Output[/align]For each test case, you should output the leftmost digit of N^N. [align=left]Sample Input[/align]2 3 4

[align=left]Sample Output[/align]
2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.


#include<stdio.h>
#include<math.h>
int main()
{
int n;
__int64 m,s;
double a;
scanf("%d",&n);
while(n--)
{
scanf("%I64d",&m);
a=m*(log(m)/log(10));
a-=(__int64)a;
s=(__int64)pow(10.0,a);
printf("%I64d\n",s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: