您的位置:首页 > 其它

dp(uva562Dividing coins)

2015-03-05 13:28 190 查看
Dividing coins

Time Limit:3000MS

Memory Limit:Unknown

64bit IO Format:%lld & %llu

SubmitStatus

Description



It's commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created
copper-wire.

Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn't stand the fact that a division should
favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...

That's what this whole problem is about. Not everyone is capable of seeing instantly what's the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.

Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It's not allowed to
split a single coin.

Input

A line with the number of problems n, followed by n times:

a line with a non negative integer m (

) indicating the number of coins in the bag

a line with m numbers separated by one space, each number indicates the value of a coin.

Output

The output consists of n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

Sample Input

2
3
2 3 5
4
1 2 4 6

Sample Output

0
1


题意:把硬币分成两队,是他们尽量想尽,问差是多少

思路:dp[i]表示值i是不是能够出现,注意循环的时候j要从大到小

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
const int maxn=110;
int N,a[maxn];
int dp[50010];
int sum;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&N);
        sum=0;
        for(int i=1;i<=N;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(int i=1;i<=N;i++)
            for(int j=sum;j>=a[i];j--)
                if(dp[j-a[i]])
                    dp[j]=1;
        int ans=0;
        for(int i=sum/2;i>0;i--)
            if(dp[i]){ans=i;break;}
        printf("%d\n",abs(sum-2*ans));
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: