您的位置:首页 > 其它

hdu 1171 Big Event in HDU 母函数解法。。以后再来用背包A一下

2015-03-04 16:50 246 查看

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 25973 Accepted Submission(s): 9139



Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).



Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding
number of the facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.



Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that
A is not less than B.



Sample Input
2
10 1
20 1
3
10 1 
20 2
30 1
-1




Sample Output
20 10
40 40



以后再也不用母函数装逼了。。TLE了十来次。。最后看的别人的代码。减少了循环次数。累觉不爱

这题 用背包明明是很简单的。。我为什么要作死

代码:

#include <stdio.h>
#include <string.h>
#define MAX 125002
int value[1100] , c[1100] ;
bool c1[MAX] , c2[MAX];
int main()
{
	int n ;
	while(~scanf("%d",&n) && n>=0)
	{
		int sum = 0;
		for(int i = 1 ; i <= n ; ++i)
		{
			scanf("%d%d",&value[i],&c[i]) ;
			sum += value[i]*c[i] ;
		}
		memset(c1,false,sizeof(c1)) ;
		memset(c2,false,sizeof(c2)) ;
		for(int i = 0 ; i <= c[1] ; ++i)
		{
			c1[i*value[1]] = true ;
		}
		int len1 = 0 , len2 = 0;
		int mid = sum/2 ;
		
		for(int i = 2 ; i <= n ; ++i)
		{
			for(int j = 0 ; j <= mid ;++j)
			{
				for(int k = 0 ; k<=c[i] && value[i]*k+j <= mid ; k++)  //循环终止条件很重要 
				{
					if(c1[j])
					{
						c2[value[i]*k+j] = true ;
					}
				}
			}
			for(int j = 0 ; j <= mid ; ++j)
			{
				c1[j] = c2[j] ;
				c2[j] = false ;
			}
		}
		
		if(c1[mid] == 0)
		{
			while(mid>0 && c1[--mid]==false) ;
			printf("%d %d\n",sum-mid,mid) ;
		}
		else
		{
			printf("%d %d\n",sum-mid,mid) ;
		}
	}
	return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: