您的位置:首页 > Web前端

POJ 2492--A Bug's Life 【并查集,向量偏移】

2015-03-03 22:03 441 查看
A Bug's Life

Time Limit: 10000MSMemory Limit: 65536K
Total Submissions: 29598Accepted: 9678
Description

Background

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy
to identify, because numbers were printed on their backs.

Problem

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each
interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual
behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.
<span style="font-size:12px;">#include <cstdio>
#include <cstring>

int p[55000];
int rank[55000];

int find (int x){
    if(x==p[x]) return x;
    int k=p[x];
    p[x]=find(p[x]);
    rank[x]=(rank[x]+rank[k])%2;
        return p[x];
}

void jion(int x,int y){
    int fx=find(x);
    int fy=find(y);
    p[fx]=fy;
    rank[fx]=(rank[y]-rank[x]+1+2)%2;
    return ;
}

int main (){
    int t,i,m,n,a,b,mark,ans=1;
    scanf("%d",&t);
    while(t--){
        mark=0;
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;++i){
            p[i]=i;
            rank[i]=0;
        }
        while(m--){
            scanf("%d%d",&a,&b);
            int fa=find(a);
            int fb=find(b);
            if(fa==fb){
                if(rank[a]==rank[b])
                    mark=1;
            }
            else jion(a,b);
        }
        if(mark)
             printf("Scenario #%d:\nSuspicious bugs found!\n\n",ans++);
        else
             printf("Scenario #%d:\nNo suspicious bugs found!\n\n",ans++);
    }
    return 0;
}
</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: