您的位置:首页 > 其它

POJ 1703--Find them, Catch them【并查集,向量偏移】

2015-03-03 22:00 453 查看
Find them, Catch them

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 33548Accepted: 10346
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given
two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]

where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]

where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output
Not sure yet.
In different gangs.
In the same gang.


<span style="font-size:12px;">/*
题目大意:在这个城市里有两个黑帮团伙,现在给出N个人,问任意两个人他们是否在同一个团伙
输入D x y代表x于y不在一个团伙里
输入A x y要输出x与y是否在同一团伙或者不确定他们在同一个团伙里
*/
#include <cstdio>
#include <cstring>

int p[100010];//存储根节点
int rank[100010];//存储该节点和根节点的关系

int find (int x){
    if(x==p[x]) return x;
    int k=p[x];
    p[x]=find(p[x]);
    rank[x]=(rank[x]+rank[k])%2;//更新该节点与根节点之间的关系
        return p[x];
}

void jion(int x,int y){
    int fx=find(x);
    int fy=find(y);
    p[fx]=fy;
    rank[fx]=(rank[y]-rank[x]+1)%2;//合并的时候求出rank[y1]
}

int main (){
    int i,t,n,m,b,c;
    char a[2];
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        for(i=0;i<=n;++i){
            p[i]=i;
            rank[i]=0;
        }
        while(m--){
            scanf("%s",a);
            //getchar();
            scanf("%d%d",&b,&c);
            if(a[0]=='A'){
                int fb=find(b);
                int fc=find(c);
                if(fb==fc){//如果根节点相同的话说明该点出现过,合并过了
                    if(rank[b]==rank[c]) printf("In the same gang.\n");//如果这两个节点均与根节点的关系相同,那么属于一个帮派
                    else printf("In different gangs.\n");
                }
                else printf("Not sure yet.\n");
            }
            else jion(b,c);
        }
    }
    return 0;
}
</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: