您的位置:首页 > 其它

POJ 1611 The Suspects (并查集+数组记录子孙个数 )

2015-03-03 20:29 239 查看
The Suspects

Time Limit: 1000MSMemory Limit: 20000K
Total Submissions: 24134Accepted: 11787
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are
many student groups. Students in the same group intercommunicate with
each other frequently, and a student may join several groups. To prevent
the possible transmissions of SARS, the NSYSU collects the member lists
of all student groups, and makes the following rule in their standard
operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects
when a student is recognized as a suspect. Your job is to write a
program which finds all the suspects.
Input

The
input file contains several cases. Each test case begins with two
integers n and m in a line, where n is the number of students, and m is
the number of groups. You may assume that 0 < n <= 30000 and 0
<= m <= 500. Every student is numbered by a unique integer between
0 and n−1, and initially student 0 is recognized as a suspect in all
the cases. This line is followed by m member lists of the groups, one
line per group. Each line begins with an integer k by itself
representing the number of members in the group. Following the number of
members, there are k integers representing the students in this group.
All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source

Asia Kaohsiung 2003

题目及算法分析:有n个人,编号0---n-1,m个组,输入这m组每组人的编号,每个组都是一个小集体。
假设0号人是嫌疑人,所有跟嫌疑人在一个组的都是嫌疑人。注意:如果1和0在某个组,并且1和2, 3, 4等在一个组,这些人也都是嫌疑人!
采用并查集算法进行合并计算算法,需要开辟一个数组进行0号,进行每个节点的子孙数目的统计保存。
代码:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <ctype.h>
#include <iostream>
#include <string>
#include <iomanip>
#include <algorithm>
#define N 30000

using namespace std;
int n, m;
int cnt
;
int fa
;

//0 < n <= 30000 and 0 <= m <=500
void init()
{
for(int i=0; i<N; i++)
{
fa[i]=i;
cnt[i]=1;
}
}

int findset(int x)
{
return fa[x]!=x? fa[x]=findset(fa[x]):x;
}

void union_set(int x, int y)
{
int xx=findset(x);
int yy=findset(y);
if(xx==yy) return; //说明两元素本来就属于同一个集合 返回
else if(xx<yy) //如果x的根节点比y的根节点 小
{
fa[yy]=xx;
cnt[xx]=cnt[xx]+cnt[yy];
}
else if(xx>yy)
{
fa[xx]=yy;
cnt[yy]=cnt[yy]+cnt[xx];
}
}

int main()
{
int dd, a, b;
while(scanf("%d %d", &n, &m)!=EOF)
{
if(n==0 && m==0) break;
init();
for(int i=0; i<m; i++)
{
scanf("%d", &dd);
scanf("%d", &a);
for(int j=0; j<dd-1; j++)
{
scanf("%d", &b);
union_set(a, b);
a=b;
}
}
printf("%d\n", cnt[0] );
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: