您的位置:首页 > 其它

UVa 202 Repeating Decimals

2015-03-03 17:48 316 查看


 Repeating Decimals 
The decimal expansion of the fraction 1/33 is 

 , where the 

 is
used to indicate that the cycle 03 repeats indefinitely with no intervening digits. In fact, the decimal expansion of every rational number (fraction) has a repeating cycle as opposed to decimal expansions of irrational numbers, which have no such repeating
cycles.

Examples of decimal expansions of rational numbers and their repeating cycles are shown below. Here, we use parentheses to enclose the repeating cycle rather than place a bar over the cycle.



Write a program that reads numerators and denominators of fractions and determines their repeating cycles.

For the purposes of this problem, define a repeating cycle of a fraction to be the first minimal length string of digits to the right of the decimal that repeats indefinitely with no intervening digits.
Thus for example, the repeating cycle of the fraction 1/250 is 0, which begins at position 4 (as opposed to 0 which begins at positions 1 or 2 and as opposed to 00 which begins at positions 1 or 4).

Input

Each line of the input file consists of an integer numerator, which is nonnegative, followed by an integer denominator, which is positive. None of the input integers exceeds 3000. End-of-file indicates
the end of input.

Output

For each line of input, print the fraction, its decimal expansion through the first occurrence of the cycle to the right of the decimal or 50 decimal places (whichever comes first), and the length of
the entire repeating cycle.
In writing the decimal expansion, enclose the repeating cycle in parentheses when possible. If the entire repeating cycle does not occur within the first 50 places, place a left parenthesis where the
cycle begins - it will begin within the first 50 places - and place ``...)" after the 50th digit.
Print a blank line after every test case.

Sample Input

76 25
5 43
1 397


Sample Output

76/25 = 3.04(0)
1 = number of digits in repeating cycle

5/43 = 0.(116279069767441860465)
21 = number of digits in repeating cycle

1/397 = 0.(00251889168765743073047858942065491183879093198992...)
99 = number of digits in repeating cycle


#include "stdio.h"
#include "string.h"

int decimal[10000];
int num[10000];

int main()
{
int n, d;
int num_count = 0;
while(scanf("%d", &n) != EOF)
{
scanf("%d", &d);
num_count++;
/*
if(num_count > 1)
printf("\n");
*/if(n == 0)
{
printf("%d/%d = 0.(0)\n", n, d);
printf("   1 = number of digits in repeating cycle\n\n");
}
else if(n % d == 0)
{
printf("%d/%d = %d.(0)\n", n, d,n/d);
printf("   1 = number of digits in repeating cycle\n\n");
}
else
{
memset(decimal, 0, sizeof(decimal));
memset(num, 0, sizeof(num));
int count = 0;
int flag = 0;
int end = 0;
int begin = 0;
int k = n;
if(k > d)
k = k % d;
k = k * 10;
while(1)
{
while(k < d)
{
decimal[count] = 0;
num[count] = k;
for(int i = count - 1; i >= 0; i--)
{
if(num[count] == num[i])
{
flag = 1;
begin = i;
end = count -1;
//              	printf("begin: %d, end: %d\n", begin, end);
break;
}
}
count++;
if(flag)
break;
k = k * 10;
}
if(flag)
break;
decimal[count] = k / d;
num[count] = k;
for(int i = count - 1; i >= 0; i--)
{
if(num[count] == num[i])
{
flag = 1;
begin = i;
end = count -1;
//		printf("begin: %d, end: %d\n", begin, end);
break;
}
}
count++;
k = k % d * 10;
if(k == 0)
{
decimal[count] = 0;
num[count] = 0;
flag = 1;
begin = count;
end = count;
count++;
//	printf("begin: %d, end: %d\n", begin, end);
}
if(flag)
break;
}
printf("%d/%d = %d.", n, d, n/d);
int i;
for(i = 0; i < 50 && i <= end; i++)
{
if(i == begin)
printf("(");
printf("%d", decimal[i]);
if(i == end)
printf(")");
}
if(i == 50 && i <= end)
printf("...)");
printf("\n");
printf("   %d = number of digits in repeating cycle\n\n", end-begin+1);
}
}
return 0;
}


方法不是最佳,一开始摸不着头脑,后来发现一步步模拟手工做除法的过程就可以得到精确的商,然后注意到只要有在某一步中有重复的被除数出现,那么就会有循环。

另外,输出格式Print a blank line after every test case.是大坑!和前一篇正好相反
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: