您的位置:首页 > 运维架构

Copying Books - UVa 714 dp

2015-03-02 08:33 337 查看


Copying Books

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several
months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire
more scribers.

Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books.
Imagine you have m books (numbered

) that may have different number of pages (

)
and you want to make one copy of each of them. Your task is to divide these books among k scribes,

. Each book can be assigned
to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers

such
that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore,
our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k,

.
At the second line, there are integers

separated by spaces. All these values are positive and less than 10000000.

Output

For each case, print exactly one line. The line must contain the input succession

divided
into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character (`/') to separate the parts. There must be exactly one space character between any two successive numbers and between
the number and the slash.

If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

Sample Input

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100


Sample Output

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100


题意:有n本书,m个人,每本书有相应的时间花费。每个人只能抄序列中连续的书,并且每人至少抄一本书。求使得最大花费时间最小的分配方式。如果有多解尽量使前面的人的工作量小。

思路:dp[i][j]表示i个人抄前j本书的最大花费时间的最小值。dp[i][j]=min(dp[i][j],max(dp[i-1][k],sum[j]-sum[k]));然后求得这个值之后,从后往前贪心地尽量让后面的人多做。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
ll num[1010],sum[1010],dp[1010][1010],INF=1e18;
int T,t,n,m,ans[1010];
int main()
{
    int i,j,k,pos,a,b,p;
    ll ret,maxn;
    scanf("%d",&T);
    for(t=1;t<=T;t++)
    {
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
        {
            scanf("%lld",&num[i]);
            sum[i]=sum[i-1]+num[i];
        }
        for(i=1;i<=n;i++)
           dp[1][i]=sum[i];
        for(i=2;i<=m;i++)
           for(j=i;j<=n;j++)
           {
               dp[i][j]=INF;
               for(k=i-1;k<j;k++)
                  dp[i][j]=min(dp[i][j],max(dp[i-1][k],sum[j]-sum[k]));
           }
        memset(ans,0,sizeof(ans));
        maxn=dp[m]
;
        p=m;
        for(i=n;i>=1;)
        {
            ret=0;
            j=i;
            while(j>p && sum[i]-sum[j-2]<=maxn)
              j--;
            p--;
            ans[j]=1;
            i=j-1;
        }
        printf("%lld",num[1]);
        for(i=2;i<=n;i++)
        {
            if(ans[i]==1)
              printf(" /");
            printf(" %lld",num[i]);
        }
        printf("\n");
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: