您的位置:首页 > 其它

POJ 2046 Power Strings KMP(next数组应用)

2015-03-01 13:15 309 查看
Power Strings

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 34646Accepted: 14338
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation
as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million
characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
Source
Waterloo local 2002.07.01

长知识了这回,没想到next[len]是本题的关键,以前总是以为next访问不到len,算了一下,还真能访问到,这回赚了。。。。。

#include <stdio.h>
#include <string.h>

char s[1000010];
int next[1000010];

void getnext(int len)
{
int i = 0,j = -1;
next[i] = j;
while(i < len)
{
if(j == -1 || s[i] == s[j])
{
i++;
j++;
if(s[i] != s[j])
next[i] = j;
else
next[i] = next[j];
// next[i] = j;也是可以的
}
else
j = next[j];
}
}

int main()
{
while(scanf("%s",s),strcmp(".",s))
{
int len = strlen(s);
getnext(len);
if(len % (len - next[len]) == 0)
printf("%d\n",len / (len - next[len]));
else
printf("1\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: