您的位置:首页 > 其它

hdoj 5018 Revenge of Fibonacci

2015-03-01 12:49 387 查看

Revenge of Fibonacci

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 839 Accepted Submission(s): 373



Problem Description
In mathematical terms, the sequence Fn of Fibonacci numbers is defined by the recurrence relation

Fn = Fn-1 + Fn-2

with seed values F1 = 1; F2 = 1 (sequence A000045 in OEIS).

---Wikipedia

Today, Fibonacci takes revenge on you. Now the first two elements of Fibonacci sequence has been redefined as A and B. You have to check if C is in the new Fibonacci sequence.


Input
The first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers A, B and C.

[Technical Specification]

1. 1 <= T <= 100

2. 1 <= A, B, C <= 1 000 000 000



Output
For each test case, output “Yes” if C is in the new Fibonacci sequence, otherwise “No”.


Sample Input
3
2 3 5
2 3 6
2 2 110




Sample Output
Yes
No
Yes
HintFor the third test case, the new Fibonacci sequence is: 2, 2, 4, 6, 10, 16, 26, 42, 68, 110…



各种错误。。。终于过了!

#include<stdio.h>
#define max 100000
int dp[max];
int main()
{
    int t,a,b,c,i;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&a,&b,&c);
        if(c==a||c==b)
        {
            printf("Yes\n");
            continue;
        }
        dp[1]=a;dp[2]=b;
        for(i=3;;i++)
        {
            dp[i]=dp[i-1]+dp[i-2];
            if(dp[i]==c)
            {
                printf("Yes\n");
                break;
            }
            if(dp[i]>c)
            {
                printf("No\n");
                break;
            }
        }
    }
    return 0; 
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: