您的位置:首页 > 其它

UVA - 548 Tree

2015-03-01 10:14 274 查看
Description





You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values
of nodes along that path.

Input

The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated
with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have
more than 10000 nodes or less than 1 node.

Output

For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.

Sample Input

3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255


Sample Output

1
3
255

建树啊 DFS啊 不会啊 留代码啊

#include <bits/stdc++.h>
using namespace std;
struct Node
{
Node *left,*right;
int v;
Node():left(NULL),right(NULL) {}
};
Node *root;
vector<int> ans;
vector<Node* > d;
int READ(int a[])
{
string s;
int i=0,x;
if(!getline(cin,s))
return false;
stringstream ss(s);
while(ss>>x)
a[i++]=x;
return i;
}
void Build(Node *&node,int a[],int b[],int n)
{
if (n == 0)
{
node = NULL;
return;
}
int mid = n - 1;
while (b[n-1] != a[mid]) mid--;
node = new Node;
node->v = b[n-1];
Build(node->left, a, b, mid);
Build(node->right, a+mid+1, b+mid, n-mid-1);
}
void dfs(Node *node,int n)
{
if(!node->left&&!node->right)
{
ans.push_back(n+node->v);
d.push_back(node);
}
if (node->left) dfs(node->left, n + node->v);
if (node->right) dfs(node->right, n + node->v);
}
int main()
{
int a[10005],b[10005],n;
while(READ(a))
{
n=READ(b);
Build(root,a,b,n);
dfs(root, 0);
int min = 0;
for (int i = 0; i <ans.size(); i++)
if (ans[i] < ans[min]) min = i;
printf("%d\n", d[min]->v);
ans.clear();
d.clear();
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: