您的位置:首页 > 其它

【题解】-航电OJ1013 Digital Roots

2015-02-28 01:04 309 查看
Problem Description The digital root of a positive integer is found by

summing the digits of the integer. If the resulting value is a single

digit then that digit is the digital root. If the resulting value

contains two or more digits, those digits are summed and the process

is repeated. This is continued as long as necessary to obtain a single

digit.

For example, consider the positive integer 24. Adding the 2 and the 4

yields a value of 6. Since 6 is a single digit, 6 is the digital root

of 24. Now consider the positive integer 39. Adding the 3 and the 9

yields 12. Since 12 is not a single digit, the process must be

repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the

digital root of 39.

Input The input file will contain a list of positive integers, one per

line. The end of the input will be indicated by an integer value of

zero.

Output For each integer in the input, output its digital root on a

separate line of the output.

Sample Input

24 39 0

Sample Output

6 3

题目考查九余数定理。

#include <stdio.h>
#include <string.h>

char n[10001];

int add_digital(const char* str){
int result = 0;
char* pointer = (char*)str;
while(*pointer){
result += *pointer - 48;
pointer++;
}
return result;
}

int main(){
while(scanf("%s",n)){
if(!strcmp(n,"0")) break;
int sum = add_digital(n);
printf("%d\n",(sum - 1)%9 + 1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: