您的位置:首页 > 编程语言 > Go语言

POJ 题目3107 Godfather(树的重心)

2015-02-27 22:09 357 查看
Godfather

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 4999Accepted: 1729
Description

Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There are n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the
data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented
by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected
component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input

The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤ n ≤ 50 000). Let them be numbered from 1 to n.

The following n − 1 lines contain two integer numbers each. The pair ai, bi means that the gangster ai has communicated with the gangster bi. It is guaranteed that the
gangsters’ communications form a tree.

Output

Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input
6
1 2
2 3
2 5
3 4
3 6

Sample Output
2 3

Source

Northeastern Europe 2005, Northern Subregion

ac代码

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define INF 0xfffffff
#define max(a,b) (a>b?a:b)
int head[50050],vis[50050],n,k,ans[50050],cot,son[50050],size;
struct s
{
int u,v,next;
}edge[50050*2];
int cmp(const void *a,const void *b)
{
return *(int *)a-*(int *)b;
}
void add(int u,int v)
{
edge[cot].u=u;
edge[cot].v=v;
edge[cot].next=head[u];
head[u]=cot++;
}
void dfs(int u)
{
vis[u]=1;
son[u]=0;
int temp=0;
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].v;
if(!vis[v])
{
dfs(v);
son[u]+=son[v]+1;
temp=max(temp,son[v]+1);
}
}
temp=max(temp,n-son[u]-1);
if(temp<size)
{
k=0;
ans[k++]=u;
size=temp;
}
else
if(temp==size)
{
ans[k++]=u;
}
}
int main()
{
//int n;
while(scanf("%d",&n)!=EOF)
{
int i;
memset(head,-1,sizeof(head));
cot=0;
for(i=0;i<n-1;i++)
{
int u,v;
scanf("%d%d",&u,&v);
add(u,v);
add(v,u);
}
k=0;
memset(vis,0,sizeof(vis));
size=INF;
dfs(1);
qsort(ans,k,sizeof(ans[0]),cmp);
printf("%d",ans[0]);
for(i=1;i<k;i++)
printf(" %d",ans[i]);
printf("\n",k);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: