您的位置:首页 > 其它

Card Collector - HDU 4336 状压期望dp

2015-02-27 19:57 337 查看


Card Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2848 Accepted Submission(s): 1359

Special Judge


Problem Description

In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.



Input

The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to
appear in a bag of snacks.

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.



Output

Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.



Sample Input

1
0.1
2
0.1 0.4




Sample Output

10.000
10.500




题意:给定每次抽到n种卡片的概率,问收集全部卡片的期望是多少。

思路:状压dp,dp[S]表示已经收集S的卡片的时候,还需要收集的卡片的期望是多少。比如dp[1010]=dp[1110]*p3+dp[1011]*p1+dp[1010]*(1-p1-p3)+1

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
int n;
double p[30],dp[4000010],ret;
int main()
{
    int i,j,k,S,MAXS,S2;
    while(~scanf("%d",&n))
    {
        for(i=0;i<n;i++)
           scanf("%lf",&p[i]);
        MAXS=(1<<n)-1;
        dp[MAXS]=0;
        for(S=MAXS-1;S>=0;S--)
        {
            dp[S]=0;
            ret=0;
            for(i=0;i<n;i++)
               if((S&(1<<i))==0)
               {

                   dp[S]+=dp[S+(1<<i)]*p[i];
                   ret+=p[i];
               }
            dp[S]=(dp[S]+1)/ret;
        }
        printf("%.5f\n",dp[0]);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: