您的位置:首页 > 其它

Anagram poj 1256

2015-02-27 03:25 411 查看
Anagram

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 18113Accepted: 7365
Description

You are to write a program that has to generate all possible words from a given set of letters.

Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba".

In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.

Input

The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered
different. The length of each word is less than 13.
Output

For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before
the corresponding lower case letter.
Sample Input
3
aAb
abc
acba

Sample Output
Aab
Aba
aAb
abA
bAa
baA
abc
acb
bac
bca
cab
cba
aabc
aacb
abac
abca
acab
acba
baac
baca
bcaa
caab
caba
cbaa

Hint

An upper case letter goes before the corresponding lower case letter.

So the right order of letters is 'A'<'a'<'B'<'b'<...<'Z'<'z'.
Source
Southwestern European Regional Contest 1995

#include <iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
using namespace std;
int len;
char ch[15],ss[15];
int visted[15];
bool cmp(char a,char b){
  double t1=a,t2=b;
  if(a>='A'&&a<='Z') t1+=31.5;
  if(t2>='A'&&t2<='Z') t2+=31.5;
  return t1<t2;
}
void dfs(int x){
	if(x==len){
	  char str[15];
	  for(int i=0;i<len;++i)
		  //str[i]=ch[i];
	  //str[len]='\0';
	  printf("%c",ch[i]);
	  printf("\n");
	}
	else{
		for(int i=0;i<len;++i){
			if(!visted[i]){
			  ch[x]=ss[i];
			  visted[i]=1;
			  dfs(x+1);
			  visted[i]=0;
			  while(i+1<len&&ss[i+1]==ss[i])i++;
			}
		}
	}
}
int main(){
  int numcase;
  scanf("%d",&numcase);
  while(numcase--){
	memset(visted,0,sizeof(visted));
    ss[15];
	scanf("%s",ss);
	len=strlen(ss);
    sort(ss,ss+len,cmp);
	dfs(0);
  }
  return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: