您的位置:首页 > 其它

POJ题目1840 Eqs(hash)

2015-02-26 22:57 381 查看
Eqs

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 12949Accepted: 6349
Description

Consider equations having the following form:

a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0

The coefficients are given integers from the interval [-50,50].

It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.
Output

The output will contain on the first line the number of the solutions for the given equation.
Sample Input
37 29 41 43 47

Sample Output
654

Source

Romania OI 2002

用int超内存

ac代码

#include<stdio.h>
#include<string.h>
short hash[25000020];
int sum;
int a,b,c,d,e;
void sol()
{
int i,j,k;
memset(hash,0,sizeof(hash));
for(i=-50;i<=50;i++)
for(j=-50;j<=50;j++)
for(k=-50;k<=50;k++)
{
if(i==0||j==0||k==0)
continue;
int res=a*i*i*i+b*j*j*j+c*k*k*k;
if(res<0)
res+=25000000;
hash[res]++;
}
}
void fun()
{
int i,j;
for(i=-50;i<=50;i++)
for(j=-50;j<=50;j++)
{
if(i==0||j==0)
continue;
int res=d*i*i*i+e*j*j*j*-1;
if(res<0)
res=25000000+res;
sum+=hash[res];
}
}
int main()
{
//	int a,b,c,d,e;
while(scanf("%d%d%d%d%d",&a,&b,&c,&d,&e)!=EOF)
{
int i,j,k;
sum=0;
sol();
fun();
printf("%d\n",sum);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: