您的位置:首页 > 其它

HDOJ 题目1496 Equations(hash)

2015-02-26 21:56 411 查看

Equations

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5860 Accepted Submission(s): 2371



[align=left]Problem Description[/align]
Consider equations having the following form:

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0

a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.

[align=left]Input[/align]
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.

End of file.

[align=left]Output[/align]
For each test case, output a single line containing the number of the solutions.

[align=left]Sample Input[/align]

1 2 3 -4
1 1 1 1


[align=left]Sample Output[/align]

39088
0


[align=left]Author[/align]
LL

[align=left]Source[/align]
“2006校园文化活动月”之“校庆杯”大学生程序设计竞赛暨杭州电子科技大学第四届大学生程序设计竞赛

[align=left]Recommend[/align]
LL | We have carefully selected several similar problems for you: 1280 1264 2600 1493 1498
ac代码
#include<stdio.h>
#include<string.h>
#include<math.h>
int hash[2000020];
int main()
{
int a,b,c,d;
while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF)
{
int i,j;
memset(hash,0,sizeof(hash));
if(a>0&&b>0&&c>0&&d>0||a<0&&b<0&&c<0&&d<0)
{
printf("0\n");
continue;
}
for(i=1;i<=100;i++)
for(j=1;j<=100;j++)
{
hash[1000000+i*i*a+j*j*b]++;
}
int sum=0;
for(i=1;i<=100;i++)
for(j=1;j<=100;j++)
if(hash[1000000-i*i*c-j*j*d])
sum+=hash[1000000-i*i*c-j*j*d];
printf("%d\n",sum*16);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: