您的位置:首页 > 其它

九度OJ题目1041:Simple Sorting

2015-02-24 23:40 316 查看
题目1041:Simple Sorting

时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:4072

解决:1520

题目描述:

You are given an unsorted array of integer numbers. Your task is to sort this array and kill possible duplicated elements occurring in it.

输入:

For each case, the first line of the input contains an integer number N representing the quantity of numbers in this array(1≤N≤1000). Next N lines contain N integer numbers(one number per each line) of the original array.

输出:

For each case ,outtput file should contain at most N numbers sorted in ascending order. Every number in the output file should occur only once.

样例输入:
6
8 8 7 3 7 7


样例输出:
3 7 8


来源:2008年上海交通大学计算机研究生机试真题

答疑:
解题遇到问题?分享解题心得?讨论本题请访问:http://t.jobdu.com/thread-7765-1-1.html

这个题也是排序而已,不同之处在于,要求我们剔除重复元素,我们未必真的剔除,只需在输出中体现就行,测试样例,输出为王!!!!!
#include <stdio.h>
#include <algorithm>

using namespace std;
int arr[1010];
int main()
{
int n,i;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;++i)
scanf("%d",&arr[i]);
sort(arr,arr+n);
int tmp=arr[0]+1;
int numN=arr[n-1];
for(i=0;i<n;++i)
{
if(arr[i]==numN)
{
printf("%d\n",numN );
break;
}
if(arr[i]==tmp)
continue;
else
{
tmp=arr[i];
printf("%d ",arr[i]);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: