您的位置:首页 > 其它

HDU 1251 统计难题 (Trie树 模板题)

2015-02-23 13:47 381 查看

统计难题

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131070/65535 K (Java/Others)

Total Submission(s): 19874 Accepted Submission(s): 8709

Problem Description

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).



Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.



Output
对于每个提问,给出以该字符串为前缀的单词的数量.



Sample Input
banana
band
bee
absolute
acm

ba
b
band
abc




Sample Output
2
3
1
0




题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1251

题目分析:裸的字典树,贴个模板,注意查找样例输入要用scanf,用gets也能过,但是不知道为什么。。。

#include <cstdio>
#include <cstring>
char s[11];

struct node
{
    node *next[26];
    int cnt;
    node()
    {
        memset(next, NULL, sizeof(next));
        cnt = 0;
    }
};

void Insert(node *p, char *s)
{   
    for(int i = 0; i < strlen(s); i++)
    {
        int idx = s[i] - 'a';
        if(p -> next[idx] == NULL)
            p -> next[idx] = new node();
        p = p -> next[idx];
        p -> cnt++;
    }
}

int Search(node *p, char *s)
{
    for(int i = 0; i < strlen(s); i++)
    {
        int idx = s[i] - 'a';
        if(p -> next[idx] == NULL)
            return 0;
        p = p -> next[idx];
    }
    return p -> cnt;
}

int main()
{
    node *root = new node();
    while(gets(s) && (strlen(s)))
        Insert(root, s);
    while(scanf("%s", s) != EOF)
        printf("%d\n", Search(root, s));
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: