您的位置:首页 > 其它

POJ 1651 Multiplication Puzzle(区间dp)

2015-02-22 15:39 375 查看
Language:
Default

Multiplication Puzzle

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6693Accepted: 4083
Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on
the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output

Output must contain a single integer - the minimal score.
Sample Input
6
10 1 50 50 20 5

Sample Output
3650

Source

Northeastern Europe 2001, Far-Eastern Subregion

题意

是n个数相乘,每次从中抽取一个数出来与相邻两个数相乘,直到抽到只剩两个数字,第一个数和最后一个数不能抽。

dp[i][j] 表示以 i j,结尾的抽法的最小值

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

#define INF 0x3f3f3f3f

#define N 105

int dp

,n,a
;

int main()
{
	int i,j;
	while(~scanf("%d",&n))
	{
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);

		memset(dp,0,sizeof(dp));

		for(i=0;i<n-2;i++)
			dp[i][i+2]=a[i]*a[i+1]*a[i+2];

		for(i=n-3;i>=0;i--)
			for(j=i+2;j<n;j++)
			{
			   dp[i][j]=dp[i+1][j]+a[i]*a[i+1]*a[j];
			   for(int k=i+1;k<j;k++)
					dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]+a[i]*a[k]*a[j]);
			}

		printf("%d\n",dp[0][n-1]);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: