您的位置:首页 > 其它

POJ 1611 The Suspects ——并查集

2015-02-20 23:36 357 查看
The Suspects

Time Limit: 1000MSMemory Limit: 20000K
Total Submissions: 24066Accepted: 11751
Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize
transmission to others, the best strategy is to separate the suspects from others. 

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 

Once a member in a group is a suspect, all members in the group are suspects. 

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number
of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one
line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least
one space. 

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

Source
Asia Kaohsiung 2003

意思是:0是sars的感染者,凡是和他是一组的同学都是感染者嫌疑人,计算最多有多少嫌疑人。

思路:并查集记录,最后检查和0相连接的个数是多少,就是并查集的以0为参数的查找函数的返回值和谁相等,谁就是嫌疑人,计数变量++。。。。。

两次AC代码,本以为后一个是前一个的优化,会是0毫秒AC,结果和第一个一样,都是16毫秒。。。。。

#include <stdio.h>
#include <string.h>

int s[300010];

int nfind(int x)
{
int r = x,q;
while(x != s[x])
x = s[x];
while(s[r] != x)
{
q = s[r];
s[r] = x;
r = q;
}
return x;
}

void lj(int x,int y)
{
int fx = nfind(x);
int fy = nfind(y);
if(fx != fy)
s[fx] = fy;
}

int main()
{
int n,m,k,x,y,mx;
while(scanf("%d%d",&n,&m),n || m)
{
mx = 0;
for(int i = 0;i <= n;i++)
s[i] = i;
for(int i = 0;i < m;i++)
{
scanf("%d",&k);
if(k > 1)
{
scanf("%d",&x);
if(mx < x)
mx = x;
for(int j = 1;j < k;j++)
{
scanf("%d",&y);
if(mx < y)
mx = y;
lj(x,y);
}
}
else if(k == 1)
{
scanf("%d",&x);
}
}
int bj = nfind(0);
int sum = 0;
for(int i = 0;i <= mx;i++)
{
if(nfind(i) == bj)
sum++;
}
printf("%d\n",sum);
}
return 0;
}

第二篇代码:

#include <stdio.h>
#include <string.h>

int s[30010];
int d[30010];
bool hs[30010];

int nfind(int x)
{
int r = x,q;
while(x != s[x])
x = s[x];
while(s[r] != x)
{
q = s[r];
s[r] = x;
r = q;
}
return x;
}

void lj(int x,int y)
{
int fx = nfind(x);
int fy = nfind(y);
if(fx != fy)
s[fx] = fy;
}

int main()
{
int n,m,xb,x,y,bj,k;
while(scanf("%d%d",&n,&m),n || m)
{
for(int i = 0;i <= n;i++)
s[i] = i;
memset(hs,false,sizeof(hs));
xb = 0;
while(m--)
{
scanf("%d",&k);
if(k > 1)
{
scanf("%d",&x);
if(!hs[x])
{
hs[x] = true;
d[xb++] = x;
}
for(int i = 1;i < k;i++)
{
scanf("%d",&y);
if(!hs[y])
{
hs[y] = true;
d[xb++] = y;
}
lj(x,y);
}
}
else if(k == 1)
{
scanf("%d",&x);
if(!hs[x])
{
hs[x] = true;
d[xb++] = x;
}
}
}
int sum = 0;
if(!hs[0])
sum = 1;
else
{
bj = nfind(0);
for(int i = 0;i < xb;i++)
{
if(nfind(d[i]) == bj)
sum++;
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: