您的位置:首页 > 其它

Section 1.1 PROB Friday the Thirteenth

2015-02-20 12:52 381 查看
Friday the Thirteenth

Is Friday the 13th really an unusual event?

That is, does the 13th of the month land on a Friday less often than on any other day of the week? To answer this question, write a program that will compute the frequency that the 13th of each month lands on Sunday, Monday, Tuesday, Wednesday, Thursday, Friday,
and Saturday over a given period of N years. The time period to test will be from January 1, 1900 to December 31, 1900+N-1 for a given number of years, N. N is positive and will not exceed 400.

Note that the start year is NINETEEN HUNDRED, not 1990.

There are few facts you need to know before you can solve this problem:

January 1, 1900 was on a Monday.
Thirty days has September, April, June, and November, all the rest have 31 except for February which has 28 except in leap years when it has 29.
Every year evenly divisible by 4 is a leap year (1992 = 4*498 so 1992 will be a leap year, but the year 1990 is not a leap year)
The rule above does not hold for century years. Century years divisible by 400 are leap years, all other are not. Thus, the century years 1700, 1800, 1900 and 2100 are not leap years, but 2000 is a leap year.

Do not use any built-in date functions in your computer language.

Don't just precompute the answers, either, please.


PROGRAM NAME: friday


INPUT FORMAT

One line with the integer N.


SAMPLE INPUT (file friday.in)

20


OUTPUT FORMAT

Seven space separated integers on one line. These integers represent the number of times the 13th falls on Saturday, Sunday,
Monday, Tuesday, ..., Friday.


SAMPLE OUTPUT (file friday.out)

36 33 34 33 35 35 34


这道题不是很难,就不啰嗦了…

//Friday the Thirteenth.cpp -- USACO 1.1
/*
ID: mengt201
PROG: friday
LANG: C++
*/
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <cmath>
typedef long long ll;
using namespace std;
const int maxn = 10 + 10;
const int sy = 1900;
int n, year, week[maxn], k;
bool flag;
int ayear[] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
bool leap(int x)
{
if( (x%4==0 && x%100!=0) || x%400==0 )
return true;
return false;
}
void plusweek(int x)
{
int kry;
for( int i=1; i<=12; i++ )
{
if( i==2 )
{
if( leap(x) )
kry = (ayear[i]+1)%7;
else
kry = ayear[i]%7;
}
else
kry = ayear[i]%7;

week[k]++;
k = (k+kry)%7;
}
}
int main(void)
{
freopen("friday.in", "r", stdin);
freopen("friday.out", "w", stdout);
while( cin>>n )
{
memset(week, 0, sizeof(week));
k = 6;
for( int i=0; i<n; i++ )
{
year = i + sy;
plusweek(year);
}
cout<<week[6]<<' '<<week[0];
for( int i=1; i<=5; i++ )
cout<<' '<<week[i];
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: