您的位置:首页 > 其它

【ACM菜逼解题报告】The Blocks Problem

2015-02-20 09:40 330 查看

The Blocks Problem

Background

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks.

In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of commands.

The Problem

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1 for all 0<=i<=n-1 as shown
in the diagram below:



Figure: Initial Blocks World

The valid commands for the robot arm that manipulates blocks are:

·move a onto b

where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.

·move a over b

where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.

·pile a onto b

where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked
above block a retain their order when moved.



·
pile a over b

where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved.

·quit

terminates manipulations in the block world.

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.

Input

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0<n<25.

The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered.

You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

Output

The output should consist of the final state of the blocks world. Each original block position numbered i (0<=i<=n where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed
by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line.

There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

Sample Input

10

move 9 onto 1

move 8 over 1

move 7 over 1

move 6 over 1

pile 8 over 6

pile 8 over 5

move 2 over 1

move 4 over 9

quit

Sample Output

0: 0

1: 1 9 2 4

2:

3: 3

4:

5: 5 8 7 6

6:

7:

8:

9:

简单的题目,注重对字符串读入、vector中push_back()\pop_back()\size()的练习。Liu使用的是string类对字符串进行读入,我用的C语言的方式进行的读入。第一次提交PE了,主要是因为,题目产生了误导,我已经将这里的样例输出更正了,每行前面是没有空格的。PE,Presentation Error,格式错误。

附代码如下:

#include<cstdio>
#include<vector>

using namespace std;

#define MAXN (30)

int n,a,b;
bool ismove;//移动内容:是move,为ture;是pile,为false。
bool isonto;//移动方式:是onto,为true;是over,为false。

vector<int> pile[MAXN];

bool read_char(){
char ch=getchar();
while(ch<'a'||ch>'z')ch=getchar();
if(ch=='q')return false;
if(ch=='m')ismove=true; else ismove=false;
while(ch!=' ')ch=getchar();
while(ch==' ')ch=getchar();
a=0;
while('0'<=ch&&ch<='9'){
a=a*10+ch-'0';
ch=getchar();
}
while(ch==' ')ch=getchar();
ch=getchar();
if(ch=='n')isonto=true; else isonto=false;
while(ch!=' ')ch=getchar();
while(ch==' ')ch=getchar();
b=0;
while('0'<=ch&&ch<='9'){
b=b*10+ch-'0';
ch=getchar();
}
return true;
}

bool count(int x,int y){
for(int i=0;i<pile[x].size();i++){
if(pile[x][i]==y)return true;
}
return false;
}

bool check(){
for(int i=0;i<n;i++){
if(count(i,a)&&count(i,b))return false;
}
return true;
}

void remove(int x){
int pos;
for(int i=0;i<n;i++){
if(count(i,x))pos=i;
}
int top=pile[pos].size()-1;
while(pile[pos][top]!=x){
int tmp=pile[pos][top];
pile[tmp].push_back(tmp);
pile[pos].pop_back();
top--;
}
}

void place(int x,int y){
int xpos,ypos;
for(int i=0;i<n;i++){
if(count(i,x))xpos=i;
if(count(i,y))ypos=i;
}
int top=pile[xpos].size()-1;
while(pile[xpos][top]!=x)top--;
for(int i=top;i<pile[xpos].size();i++){
pile[ypos].push_back(pile[xpos][i]);
}
while(top!=pile[xpos].size())pile[xpos].pop_back();
}

int main(){
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
scanf("%d",&n);
for(int i=0;i<n;i++)pile[i].push_back(i);
int x=0;
while(read_char()){
/*printf("%d\n",++x);
printf("%d ",a);
printf("%d\n",b);
if(x==19)break;*/
if(!check())continue;
if(ismove){
remove(a);
if(isonto)remove(b);
place(a,b);
}else{
if(isonto)remove(b);
place(a,b);
}
}
for(int i=0;i<n;i++){
printf("%d:",i);
for(int j=0;j<pile[i].size();j++){
printf(" %d",pile[i][j]);
}
printf("\n");
}
//fclose(stdin);
//fclose(stdout);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: