您的位置:首页 > 其它

ACM--steps--3.3.3--Dividing(多重背包)

2015-02-20 02:54 211 查看

Dividing

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 793 Accepted Submission(s): 266
[align=left]Problem Description[/align]
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could
just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so
that each of them gets the same total value.

Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets
of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

[align=left]Input[/align]
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described
by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.

[align=left]Output[/align]
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

Output a blank line after each test case.

[align=left]Sample Input[/align]

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0


[align=left]Sample Output[/align]

Collection #1:
Can't be divided.

Collection #2:
Can be divided.


[align=left]Source[/align]
Mid-Central European Regional Contest 1999

[align=left]Recommend[/align]
JGShining

#include<iostream>
#include<cstring>
using namespace std;
const int N=100000;
int dyx
;//用来表示是否可以被平分。
int main()
{
int T,i,j,val,temp,k;
T=1;
int wyx[9];
while(cin>>wyx[1])
{
int sum=wyx[1];
for(i=2;i<=6;i++)
{
cin>>wyx[i];
sum+=i*wyx[i];//将总价值量当成背包的容量。
}
if(!sum)
break;
cout<<"Collection #"<<T++<<":"<<endl;
if(sum%2)//和为奇数,必然不能被平分。
{
cout<<"Can't be divided."<<endl<<endl;
continue;
}
temp=sum/2;
memset(dyx,0,sizeof(dyx));
//关于多重背包的二进制转换问题。
//背包九讲里有明确解释。我只注释了大概的步骤。
dyx[0]=1;
for(i=1;i<=6;i++)
{
if(!wyx[i])
continue;
//在本题中,i表示某一品种的价值。分别为1~6,对应1~6号物品。
//而a[i]则表示为某一品种的物品的总数。
for(j=1;j<=wyx[i];j*=2)//进行二进制优化。
{
//j从1开始,注意在二进制优化的时候1,2,4,...,2^(k-1),n[i]-2^k+1,从2^0次幂开始。
val=i*j;//优化的时候,上面的1,2,4表示的是系数,还要乘以本身的价值量。
for(k=temp;k>=val;k--)
{
//这个式子写出来是,sum/2-val-1,sum/2-val-2~sum/2-val-val;
if(dyx[k-val])//只有val前面所有的物品都可以放入,再放最后的。
dyx[k]=1;
}
wyx[i]-=j;
}
val=wyx[i]*i;//经过上面的循环,还剩下一种分法。
if(val)
{
for(k=temp;k>=val;k--)
{
if(dyx[k-val])
dyx[k]=1;
}
}
}
if(dyx[temp])
cout<<"Can be divided."<<endl<<endl;
else
cout<<"Can't be divided."<<endl<<endl;
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: