您的位置:首页 > 运维架构

poj 1094 Sorting It All Out[ topo]

2015-02-19 22:39 609 查看
传送门:http://poj.org/problem?id=1094

Sorting It All Out

Description
An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and
C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will
be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters:
an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output
For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.

Sorted sequence cannot be determined.

Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.


思路:topo排序:1:判断是否有环;2:判断答案是否唯一;3:全部读入,序列不确定;

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<string>
#include<queue>
#include<stack>
#include<map>
#define INF 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;

typedef long long LL;
const int N=1002;

vector<int> E[30],ans;
int indegree[30];

int topo(int n)
{
int tmp[30];
for(int i=0;i<30;i++)
tmp[i]=indegree[i];
ans.clear();
int cnt=0,cur,flag=1;
for(int i=0;i<n;i++)
{
cnt=0;
for(int j=0;j<n;j++)
{
if(tmp[j]==0)
{
cnt++;
cur=j;
}
}
if(cnt==0) return 0;
if(cnt>1) flag=-1; //unsure
ans.push_back(cur);
tmp[cur]=-1;
for(int j=0;j<E[cur].size();j++)
{
int v=E[cur][j];
tmp[v]--;
}
}
return flag;
}

int main()
{
int n,m;
while(scanf("%d%d",&n,&m)==2){
if(n==0&&m==0) break;
char str[10];
mem(indegree,0);
for(int i=0;i<n;i++)
E[i].clear();
int ok=0;
for(int i=1;i<=m;i++){
scanf("%s",str);
E[str[0]-'A'].push_back(str[2]-'A');
indegree[str[2]-'A']++;
int res=topo(n);
if(ok) continue;
if(res==0)
{
printf("Inconsistency found after %d relations.\n",i);
ok=1;
}
if(res==1)
{
printf("Sorted sequence determined after %d relations: ",i);
for(int j=0;j<ans.size();j++)
printf("%c",ans[j]+'A');
printf(".\n");
ok=1;
}
}
if(!ok)
printf("Sorted sequence cannot be determined.\n");

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: