您的位置:首页 > 其它

hdu 4707 Pet(dfs,bfs)

2015-02-19 18:05 447 查看

Pet

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1548 Accepted Submission(s): 733



[align=left]Problem Description[/align]
One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for
three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere
nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is
always one distance unit.

[align=left]Input[/align]
The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space.
N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room
is always at location 0.

[align=left]Output[/align]
For each test case, outputin a single line the number of possible locations in the school the hamster may be found.

[align=left]Sample Input[/align]

1
10 2
0 1
0 2
0 3
1 4
1 5
2 6
3 7
4 8
6 9


[align=left]Sample Output[/align]

2dfs或者bfs解法求离树的距离>=d的节点的个数,以下两个代码均已ac
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
#define maxn 100005
int first[maxn],to[maxn],nxt[maxn],e;
void add(int u,int v){
to[e]=v;
nxt[e]=first[u];
first[u]=e++;
}
int n,d;
int sum;
bool vis[maxn];
void dfs(int u,int dep){
if(dep>d){sum++;}
for(int i=first[u];~i;i=nxt[i]){
int v=to[i];
if(!vis[v]){
vis[v]=true;
dfs(v,dep+1);
}
}
}
int dep[maxn];
void bfs(int s){
queue<int>q;
q.push(s);
while(!q.empty()){
int u=q.front();
q.pop();
for(int i=first[u];~i;i=nxt[i]){
int v=to[i];
if(!vis[v]){
vis[v]=true;
dep[v]=dep[u]+1;
q.push(v);
}
}
}
}
int main()
{
int t;
int u,v;
freopen("in.txt","r",stdin);
scanf("%d",&t);
while(t--){
sum=0;
e=0;
scanf("%d%d",&n,&d);
memset(vis,0,sizeof vis);
memset(first,-1,sizeof first);
memset(dep,0,sizeof dep);
for(int i=0;i<n-1;i++){
scanf("%d%d",&u,&v);
add(u,v);
}
vis[0]=true;
//dfs(0,0);
[code] //printf("%d\n",sum);
bfs(0);
int s=0;
for(int i=0;i<n;i++)
if(dep[i]>d)s++;
printf("%d\n",s);
}
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: