您的位置:首页 > 其它

【Uva 1585】 Score

2015-02-19 13:55 267 查看

Description

There is an objective test result such as “OOXXOXXOOO”. An ‘O’ means a correct answer of a problem and an ‘X’ means a wrong answer. The score of each problem of this test is calculated by itself and its just previous consecutive `O’s only when the answer is correct. For example, the score of the 10th problem is 3 that is obtained by itself and its two previous consecutive ‘O’s.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing a string composed by ‘O’ and ‘X’ and the length of the string is more than 0 and less than 80. There is no spaces between ‘O’ and ‘X’.

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case.

The following shows sample input and output for five test cases.

Sample Input

5

OOXXOXXOOO

OXOXOXOXOXOXOX

OOOOOOOOOO

OOOOXOOOOXOOOOX

Sample Output

10

9

7

55

30

解题思路:

我们可以用last_ch变量来存储上一个字符,若当前字符为’O’,再判断上一个字符是否也为‘O’,来决定当前的增加量 .

参考代码:

#include <stdio.h>
#include <string.h>
#define LEN strlen(str)
const int MAX = 100;
int main()
{
int T;
char str[MAX];
scanf("%d",&T);
while (T--){
memset(str,0,sizeof(str));
int ans = 0,cnt = 1;
char last_ch = 'X';
scanf("%s",str);
for (int i = 0;i < LEN;i++){
if (str[i] == 'O'){    //当前字符为'O'
if (last_ch == 'O'){    //判断上一个字符是否也为'O'
cnt++;
ans += cnt;
}else{
ans++;
cnt = 1;
}
}
last_ch = str[i];    //更新上一个字符
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: