您的位置:首页 > 其它

UVA 10382 Watering Grass

2015-02-18 14:14 1636 查看
Watering Grass

Input:
standard input

Output: standard output

Time Limit: 3 seconds

n sprinklers are installed in a horizontal strip of grass l meters long and w meters wide. Each sprinkler is installed at the horizontal center line of the strip. For each sprinkler we are given its
position as the distance from the left end of the center line and its radius of operation.
What is the minimum number of sprinklers to turn on in order to water the entire strip of grass?



Input
Input consists of a number of cases. The first line for each case contains integer numbers n, l and w with n <= 10000. The next n lines contain two integers giving the position of a
sprinkler and its radius of operation. (The picture above illustrates the first case from the sample input.)

Output
For each test case output the minimum number of sprinklers needed to water the entire strip of grass. If it is impossible to water the entire strip output -1.

Sample input

8 20 2
5 3
4 1
1 2
7 2
10 2
13 3
162
19 4
3 10 1
3 5
9 3
61
3 10 1
5 3
1 1
9 1

Sample Output

6

2
-1
区间覆盖问题,先把圆转化成线段然后按照线段的来即可。

#include<stdio.h>
#include<iostream>  
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
const int maxn = 10005;
int n, m, tot;
double sum, w, l, r;
struct abc
{
	double l, r;
	bool operator < (const abc &a)
	{
		if (a.l == l) return r > a.r;
		return l < a.l;
	}
}; abc a[maxn];

int main(){
	while (cin >> n >> m >> w)
	{
		w = w / 2;
		for (int i = 0; i < n; i++)
		{
			a[i].l = 0;
			scanf("%lf%lf", &l, &r);
			if (r>w)
			{
				a[i].l = max(a[i].l, l - sqrt(r*r - w*w));
				a[i].r = l + sqrt(r*r - w*w);
			}
			else a[i].l = a[i].r = 0;
		}
		sort(a, a + n);		sum = tot = 0;
		for (int i = 0; sum < m&&i < n;)
		{
			sum = a[i].r;	tot++;
			for (int j = i + 1; j < n&&a[j].l <= sum; j++) if (a[j].r > a[i].r) i = j;
			if (sum == a[i].r) break;
		}
		if (sum < m) printf("-1\n"); else printf("%d\n", tot);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: