您的位置:首页 > 其它

POJ 1018 Communication System (枚举+贪心)

2015-02-18 12:49 351 查看
Communication System

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 23958Accepted: 8540
Description
We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers.
Same devices from two manufacturers differ in their maximum bandwidths and prices.

By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.

Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single
integer n (1 ≤ n ≤ 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive
integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.
Output
Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal
point.

Sample Input
1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110

Sample Output
0.649

Source
Tehran 2002, First Iran Nationwide Internet Programming Contest

题目链接:http://poj.org/problem?id=1018

题目大意:需要n个设备,第i个设备有mi个厂商,每个厂商做该设备有两个参数,带宽和价格,每个设备从其中一个厂商处购得,现在定义B为n个设备中带宽的最小值,P为n个设备的总价值,求B/P的最大值

题目分析:从小到大枚举带宽,对于第i个设备,在mi个厂商中选择带宽不小于当前枚举值且价格最小的那个,正确性在于求B/P的最大值,我们就要让B尽量大,让P尽量小,因为我们在枚举B的时候取的是大于等于B的带宽,所以当前的分子B就是枚举值,然后再找满足带宽大小约束的价格尽量小的加起来就是分母P,因此对于每一个带宽我们都有一个最优解,最后取全局最优即可

#include <cstdio>
#include <algorithm>
using namespace std;
int const MAX = 105;
int const INF = 0xfffffff;
int b[MAX][MAX], p[MAX][MAX], num[MAX];

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int n, mi = INF, ma = 0;
        scanf("%d", &n);
        for(int i = 0; i < n; i++)
        {
            scanf("%d", &num[i]);
            for(int j = 0; j < num[i]; j++)
            {
                scanf("%d %d", &b[i][j], &p[i][j]);
                ma = max(ma, b[i][j]);
                mi = min(mi, b[i][j]);
            }
        }
        double ans = 0;
        for(int bw = mi; bw <= ma; bw++)
        {
            int sum = 0;
            for(int i = 0; i < n; i++)
            {
                int minp = INF;
                for(int j = 0; j < num[i]; j++)
                {
                    if(b[i][j] >= bw && p[i][j] < minp)
                        minp = p[i][j];
                }
                sum += minp;
            }
            if(bw / (sum * 1.0) > ans)
                ans = bw / (sum * 1.0);
        }
        printf("%.3f\n", ans);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: