您的位置:首页 > Web前端

UVA 825 Walking on the Safe Side

2015-02-17 21:31 155 查看
Square City is a very easy place for people to walk around. The two-way streets run North-South or East-West dividing the city into regular blocks.
Most street intersections are safe for pedestrians to cross. In some of them, however, crossing is not safe and pedestrians are forced to use the available underground passages. Such intersections are avoided by walkers. The entry to the city park is on the
North-West corner of town, whereas the railway station is on the South-East corner.

Suppose you want to go from the park to the railway station, and do not want to walk more than the required number of blocks. You also want to make your way avoiding the underground passages, that would introduce extra delay. Your task is to determine the number
of different paths that you can follow from the park to the station, satisfying both requirements.

The example in the picture illustrates a city with 4 E-W streets and 5 N-S streets. Three intersections are marked as unsafe. The path from the park to the station is 3 + 4 = 7 blocks long and there are 4 such paths that avoid the underground passages.




Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank
line, and there is also a blank line between two consecutive inputs.

The first line of the input contains the number of East-West streets W and the number of North-South streets N.
Each one of the followingW lines starts with the number of an East-West street, followed by zero or more numbers of the North-South crossings which are unsafe. Streets
are numbered from 1.


Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

The number of different minimal paths from the park to the station avoiding underground passages.


Sample Input

1

4 5
1
2 2
3 3 5
4



Sample Output

4

统计到达终点的方案数,中间会有不能走的点。

输入处理其实是关键。

#include<iostream>  
#include<algorithm>
#include<math.h>
#include<cstdio>
#include<string>
#include<string.h>
using namespace std;
const int maxn = 1001;
int x, t, n, m, i, j, f[maxn][maxn], map[maxn][maxn];
char s[1000];

int main(){
	cin >> t;
	while (t--)
	{
		cin >> n >> m;
		memset(f, 0, sizeof(f));
		memset(map, 0, sizeof(map));
		for (i = 1; i <= n; i++)
		{
			scanf("%d", &x);	gets(s);	j = 1;
			if (s[0])
			while (~sscanf(s + j, "%d", &x)) 
			{ 
				map[i][x] = -1; 
				while (s[j] != ' '&&s[j] != 0) j++;
				j++;
			}
		}
		f[1][1] = 1;
		for (i = 1; i <= n; i++)
			for (j = 1; j <= m; j++)
				if (map[i][j] == 0) f[i][j] += f[i - 1][j] + f[i][j - 1];
		printf("%d\n", f
[m]);
		if (t) printf("\n");
	}
	return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: