您的位置:首页 > 其它

UVA 208 Firetruck

2015-02-17 15:39 357 查看
The Center City fire department collaborates with the transportation department to maintain maps of the city which reflects the current status of the city streets. On any given day, several streets are closed for repairs or construction. Firefighters need to
be able to select routes from the firestations to fires that do not use closed streets.

Central City is divided into non-overlapping fire districts, each containing a single firestation. When a fire is reported, a central dispatcher alerts the firestation of the district where the fire is located and gives a list of possible routes from the firestation
to the fire. You must write a program that the central dispatcher can use to generate routes from the district firestations to the fires.


Input

The city has a separate map for each fire district. Streetcorners of each map are identified by positive integers less than 21, with the firestation always on corner #1. The input file contains several test cases representing different fires in different districts.

The first line of a test case consists of a single integer which is the number of the streetcorner closest to the fire.
The next several lines consist of pairs of positive integers separated by blanks which are the adjacent streetcorners of open streets. (For example, if the pair 4 7 is on a line in the file, then the street between streetcorners 4 and 7 is open. There are
no other streetcorners between 4 and 7 on that section of the street.)
The final line of each test case consists of a pair of 0's.


Output

For each test case, your output must identify the case by number (CASE #1, CASE #2, etc). It must list each route on a separate line, with the streetcorners written in the order in which they appear on the route. And it must give the total
number routes from firestation to the fire. Include only routes which do not pass through any streetcorner more than once. (For obvious reasons, the fire department doesn't want its trucks driving around in circles.)

Output from separate cases must appear on separate lines.

The following sample input and corresponding correct output represents two test cases.


Sample Input

6
1 2
1 3
3 4
3 5
4 6
5 6
2 3
2 4
0 0
4
2 3
3 4
5 1
1 6
7 8
8 9
2 5
5 7
3 1
1 8
4 6
6 9
0 0



Sample Output

CASE 1:
1 2 3 4 6
1 2 3 5 6
1 2 4 3 5 6
1 2 4 6
1 3 2 4 6
1 3 4 6
1 3 5 6
There are 7 routes from the firestation to streetcorner 6.
CASE 2:
1 3 2 5 7 8 9 6 4
1 3 4
1 5 2 3 4
1 5 7 8 9 6 4
1 6 4
1 6 9 8 7 5 2 3 4
1 8 7 5 2 3 4
1 8 9 6 4
There are 8 routes from the firestation to streetcorner 4.

求所有到达终点的路径,递归。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
#include<math.h>
using namespace std;
const int maxn = 101;
int t, sum, n, m, x, y, z, tot = 1;
int f[maxn][maxn], c[maxn], d[maxn], e[maxn];

void ss(int x)
{
	for (int i = 1; i <= z;i++)
		if (f[x][i] && c[i] == 0)
		{
			c[i] = 1; ss(i);
		}
}

void work(int x, int y)
{
	e[y] = x;
	if (x == t)
	{
		for (int i = 1; i < y; i++) printf("%d ", e[i]);
		printf("%d\n", e[y]);	sum++;
		return;
	}
	for (int i = 1; i <= z; i++)
		if (c[i] && f[x][i] && !d[i])
		{
			d[i] = 1;
			work(i, y + 1);
			d[i] = 0;
		}
}

int main()
{
	while (cin >> t)
	{
		memset(f, 0, sizeof(f));
		memset(d, 0, sizeof(d));
		memset(c, 0, sizeof(c));
		z = 0;
		while (cin >> x >> y, x, y) f[x][y] = f[y][x] = 1, z = max(z, max(x, y));
		sum = 0; c[t] = 1; ss(t);
		cout << "CASE " << tot++ << ":" << endl;
		d[1] = 1; work(1, 1);
		cout << "There are " << sum << " routes from the firestation to streetcorner " << t << "." << endl;
	}
	return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: