您的位置:首页 > 其它

HDU 1372---- Knight Moves (广搜)

2015-02-15 18:31 218 查看
在国际象棋中Knight称“马”或“骑士”,Knight的走法和中国象棋中马相同,
同样是走“日”字,或英文字母大写的“L”形
另外此题充分利用队列!!!

Description

Background

Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?

The Problem

Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.

For people not familiar with chess, the possible knight moves are shown in Figure 1.



Input

The input begins with the number n of scenarios on a single line by itself.

Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers
{0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The
distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1


Sample Output

5
28
0


#include<stdio.h>

#include<string.h>
int used[305][305],step[305][305];
int n,ex,ey,a,b;
int direction[8][2]={2,1,1,2,-1,2,-2,1,-2,-1,-1,-2,1,-2,2,-1}; //注意方向数组的初始化!!!
struct chess
{
int x;
int y;
}queue[90005];
void bfs(int sx,int sy)
{
int head=0,tail=1,i,x,y;
queue[head].x=sx;   //把他的值再赋值给另一个变量是因为,这实际上就是一个队列,每回都要把队首舍弃!!!!
queue[head].y=sy;
used[sx][sy]=1;
while(head<tail)
{
x=queue[head].x;
y=queue[head].y;
for(i=0;i<8;i++)
{
a=x+direction[i][0];
b=y+direction[i][1];
if(a<n&&a>=0&&b<n&&b>=0&&used[a][b]==0) //判断是否越界和被访问
{
used[a][b]=1;
step[a][b]=step[x][y]+1;//这是这个题最重要的一点!!!
queue[tail].x=a;
queue[tail].y=b;
tail++;
}
if(a==ex&&b==ey) return ;

}
head++;
}
}
int main(void)
{
int T,sx,sy;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
scanf("%d%d",&sx,&sy);
scanf("%d%d",&ex,&ey);
memset(used,0,sizeof(used));
memset(step,0,sizeof(step));
if(sx==ex&&sy==ey)
{
printf("0\n");
continue;
}
bfs(sx,sy);
printf("%d\n",step[a][b]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: