您的位置:首页 > 其它

UVA 10305- Ordering Tasks(经典拓扑排序)

2015-02-15 01:20 387 查看
Problem F
Ordering Tasks
Input: standard input
Output: standard output
Time Limit: 1 second
Memory Limit: 32 MB

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and m. n is the number of tasks (numbered from 1 to n)
and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed
before task j. An instance with n = m = 0 will finish the input.
Output

For each instance, print a line with n integers representing the tasks in a possible order of execution.

Sample Input

5 4

1 2

2 3

1 3

1 5

0 0

Sample Output

1 4 2 5 3


(The Joint Effort Contest, Problem setter: Rodrigo Malta Schmidt)

懒得说题意了,就是注意,输出的数据可能和所给的事例不一样,只要符合其中一种就好。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>

using namespace std;
int n,m,i,j,k,u,v;
int map[110][110];
int ans[110];
int in[110];
int topo()
{
for(i=1;i<=n;i++){
k=1;
while(in[k])
k++;
ans[i]=k;
in[k]=-1;
for(j=1;j<=n;j++)
if(map[k][j])
in[j]--;
}
}
int main()
{
while(~scanf("%d %d",&n,&m)){
if(n==0&&m==0) break;
memset(map,0,sizeof(map));
memset(in,0,sizeof(in));
memset(ans,0,sizeof(ans));
for(i=1;i<=m;i++){
scanf("%d %d",&u,&v);
if(map[u][v]==0){
map[u][v]=1;
in[v]++;
}
}
topo();
for(i=1;i<n;i++)
printf("%d ",ans[i]);
printf("%d\n",ans[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: