您的位置:首页 > 其它

POJ 2253 Frogger (Floyd 松弛操作)

2015-02-15 00:18 465 查看
Frogger
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 27365Accepted: 8897
Description
Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen,
he wants to avoid swimming and instead reach her by jumping.

Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.

To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000)
representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate
real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source
Ulm Local 1997

题目链接:http://poj.org/problem?id=2253

题目大意:n个石头的坐标,有两只青蛙第一只在一个石头上,第二只在第二个石头上,剩下的石头上没有东西,定义青蛙距离为第一只青蛙跳到第二只青蛙那的路径上每次跳跃最长距离最小情况下的那个最长距离。

题目分析:这题不用判连通,只管松弛就好,先计算出任意两点间的距离,然后floyd跑一遍,类似最小环,k是从i到j的媒介点,通过判断i -> k和 k-> j长度是否都小于i-> j来决定要不要松弛,松弛的时候,最长距离取i->k和k->j大的那个

#include <cmath>
#include <cstdio>
using namespace std;

struct Point
{
    double x, y;
}p[201];
int n;
double path[201][201]; 

double cal(Point a, Point b)
{
    return sqrt((a.x - b.x) * (a.x - b.x) + (a.y - b.y) * (a.y - b.y));
}

void Floyd()
{
    for(int k = 1; k <= n; k++)    
        for(int i = 1; i <= n; i++)  
            for(int j = 1; j <= n; j++)
                if(path[i][k] < path[i][j] && path[k][j] < path[i][j])  
                    if(path[i][k] < path[k][j])              
                        path[i][j] = path[j][i] = path[k][j];
                    else
                        path[i][j] = path[j][i] = path[i][k];
}

int main()
{
    int ca = 1; 
    while(scanf("%d", &n) != EOF && n)
    {
        for(int i = 1; i <= n; i++)
            scanf("%lf %lf", &p[i].x, &p[i].y);
        for(int i = 1; i < n; i++)
            for(int j = i + 1; j <= n; j++)
                path[i][j] = path[j][i] = cal(p[i], p[j]); 
        Floyd();
        printf("Scenario #%d\nFrog Distance = %.3f\n\n", ca++, path[1][2]);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: