您的位置:首页 > 其它

poj 1125 Stockbroker Grapevine [ 最短路]

2015-02-13 21:45 375 查看
传送门:http://poj.org/problem?id=1125

Stockbroker Grapevine

Description
Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect,
you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass
the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community.
This duration is measured as the time needed for the last person to receive the information.
Input
Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact
with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each
pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of
stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output
For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person,
measured in integer minutes.

It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the
message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input
3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output
3 2
3 10

思路:题目大意是求,每个人和其他n-1个人联系的最长时间,其中数组最小的最长时间,以及对应的人;

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#include<queue>
#include<stack>
#include<map>
#define INF 0x3f3f3f3f
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;

typedef long long LL;
const int N=1002;

int vis
,dist
,ans_1,ans_2;
struct Edge{
int v;
int cost;
Edge(int v_,int cost_):v(v_),cost(cost_){}
};

vector<Edge> E
;

void addedge(int u,int v,int cost)
{
E[u].push_back(Edge(v,cost));
}

void spfa(int n,int s)
{
for(int i=1;i<=n;i++)
{
dist[i]=INF;
vis[i]=0;
}
queue<int> que;
que.push(s);
vis[s]=1;
dist[s]=0;
while(!que.empty()){
int u=que.front();
que.pop();
vis[u]=0;
for(int i=0;i<E[u].size();i++){
int v=E[u][i].v;
if(dist[v]>dist[u]+E[u][i].cost){
dist[v]=dist[u]+E[u][i].cost;
if(!vis[v]){
vis[v]=1;
que.push(v);
}
}
}
}
int maxx=0;
for(int i=1;i<=n;i++)
{
if(dist[i]>=INF) return;
if(dist[i]>maxx)
maxx=dist[i];
}
if(maxx<ans_1)
{
ans_1=maxx;
ans_2=s;
}
}

int main()
{
int n,m;
while(scanf("%d",&n)==1)
{
for(int i=1;i<=n;i++)
E[i].clear();
if(n==0) break;
int v,cost;
for(int u=1;u<=n;u++)
{
scanf("%d",&m);
for(int j=0;j<m;j++)
{
scanf("%d%d",&v,&cost);
addedge(u,v,cost);
}
}
ans_1=INF,ans_2=-1;
for(int i=1;i<=n;i++)
{
spfa(n,i);
}
if(ans_2==-1)
printf("disjoint\n");
else
printf("%d %d\n",ans_2,ans_1);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: