您的位置:首页 > 产品设计 > UI/UE

杭电hdu_1005_Number Sequence

2015-02-13 14:02 375 查看
Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

Output

For each test case, print the value of f(n) on a single line.

 

Sample Input

1 1 3
1 2 10
0 0 0

 

Sample Output

2
5

 

<pre name="code" class="cpp">#include<memory>
#include<iostream>
#include<string>
//#include<QPainter>
//#include<fstream>
#include<cctype>
#include<algorithm>
#include<cmath>
#include<map>
using namespace std;

int fun(int &a,int &b,int n)
{
if(n == 1) return 1;
if(n == 2) return 1;
if(n>2){
return ( a*fun(a,b,n-1) + b*fun(a,b,n-2) )%7 ;
}
}
int main(int argc, char *argv[])
{
int a,b,n;
while(cin >> a >> b >> n)
{
if(!a && !b && !n) break;
int i = fun(a,b,n%49);
cout << i << endl;
}

return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  刷题