您的位置:首页 > 其它

hdoj 1016 Prime Ring Problem

2015-02-13 10:13 176 查看

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 29586 Accepted Submission(s): 13194



Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.





Input
n (0 < n < 20).



Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in
lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.



Sample Input
6
8




Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2



dfs搜索:
#include<stdio.h>
#include<math.h>
#define max 40
int visit[max],a[max];
int n;
int prime(int x)
{
    int i;
    if(x==2||x==3) return 1;
    if(x==1) return 0;
    for(i=2;i<=sqrt(x);i++)
    {
        if(x%i==0)
        return 0;
    }
    return 1;
}
void dfs(int num,int n)
{
    int i;
    if(num==n+1&&prime(a
+1))
    {
        for(i=1;i<=n;i++)
        {
            if(i>1) printf(" ");
            printf("%d",a[i]);
        }
        printf("\n");
        return ;
    }
    else
    {
        for(i=2;i<=n;i++)
        {
            if(!visit[i]&&prime(a[num-1]+i))
            {
                visit[i]=1;
                a[num]=i;
                dfs(num+1,n);
                visit[i]=0;
            }
        }
        return ;
    }
}
int main()
{
    int i,t=1;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=1;i<=n;i++)
        {
            a[i]=0;
            visit[i]=0;
        }
        a[1]=1;visit[1]=1;
        printf("Case %d:\n",t++);
        if(n==1)
        printf("1\n");
        else
        dfs(2,n);
        printf("\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: