您的位置:首页 > 其它

zoj 1383 Binary Numbers

2015-02-11 14:16 288 查看
Binary Numbers

Time Limit: 2 Seconds Memory Limit: 65536 KB

Given a positive integer n, print out the positions of all 1's in its binary representation. The position of the least significant bit is 0.

Example

The positions of 1's in the binary representation of 13 are 0, 2, 3.

Task

Write a program which for each data set:
reads a positive integer n,

computes the positions of 1's in the binary representation of n,

writes the result.

Input

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

Output

The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.

Sample Input
1

13

Sample Output
0 2 3

分析:

将n转化为二进制数,用数组保存。循环一次,将出现1的位置输出。

代码:

#include <cstdio>
#include <cstring>

const int MAX_N = 20;

int d, n;
int bit[MAX_N];

void solve() {
int i, tot = 0;
memset(bit, 0, sizeof(bit));
for (i = 0; n != 0; n /= 2) {
bit[i++] = n % 2;
}
for (int j = 0; j < i; j++)
if (bit[j] == 1)
tot++;
for (int j = 0; j < i; j++)
if (bit[j] == 1) {
printf("%d", j);
if (tot > 1)
printf(" ");
tot--;
}
}

int main() {
scanf("%d", &d);
for (; d > 0; d--) {
scanf("%d", &n);
solve();
if (d > 1)
puts("");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: