您的位置:首页 > 其它

HDOJ题目4288 Coder(vector)

2015-02-09 21:27 225 查看

Coder

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3627 Accepted Submission(s): 1414



[align=left]Problem Description[/align]
  In mathematics and computer science, an algorithm describes a set of procedures or instructions that define a procedure. The term has become increasing popular since the advent of cheap and reliable computers. Many companies now
employ a single coder to write an algorithm that will replace many other employees. An added benefit to the employer is that the coder will also become redundant once their work is done.
1

  You are now the signle coder, and have been assigned a new task writing code, since your boss would like to replace many other employees (and you when you become redundant once your task is complete).

Your code should be able to complete a task to replace these employees who do nothing all day but eating: make the digest sum.

  By saying “digest sum” we study some properties of data. For the sake of simplicity, our data is a set of integers. Your code should give response to following operations:

  1. add x – add the element x to the set;

  2. del x – remove the element x from the set;

  3. sum – find the digest sum of the set. The digest sum should be understood by



  where the set S is written as {a1, a2, ... , ak} satisfying a1 < a2 < a3 < ... < ak

  Can you complete this task (and be then fired)?

------------------------------------------------------------------------------

1 See http://uncyclopedia.wikia.com/wiki/Algorithm
[align=left]Input[/align]
  There’re several test cases.

  In each test case, the first line contains one integer N ( 1 <= N <= 105 ), the number of operations to process.

  Then following is n lines, each one containing one of three operations: “add x” or “del x” or “sum”.

  You may assume that 1 <= x <= 109.

  Please see the sample for detailed format.

  For any “add x” it is guaranteed that x is not currently in the set just before this operation.

  For any “del x” it is guaranteed that x must currently be in the set just before this operation.

  Please process until EOF (End Of File).

[align=left]Output[/align]
  For each operation “sum” please print one line containing exactly one integer denoting the digest sum of the current set. Print 0 if the set is empty.

[align=left]Sample Input[/align]

9
add 1
add 2
add 3
add 4
add 5
sum
add 6
del 3
sum
6
add 1
add 3
add 5
add 7
add 9
sum


[align=left]Sample Output[/align]

3
4
5
HintC++ maybe run faster than G++ in this problem.


#include<stdio.h>
#include<string.h>
#include<vector>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
char s[5];
vector<int>v;
vector<int>::iterator it;
while(n--)
{
scanf("%s",s);
if(s[0]=='a')
{
int x;
scanf("%d",&x);
it=lower_bound(v.begin(),v.end(),x);
v.insert(it,x);
}
else
if(s[0]=='d')
{
int x;
scanf("%d",&x);
it=lower_bound(v.begin(),v.end(),x);
v.erase(it);
}
else
{
__int64 sum=0;
for(int i=2;i<v.size();i+=5)
{
sum+=v[i];
}
printf("%I64d\n",sum);
}
}
}
}


[align=left]Source[/align]
2012 ACM/ICPC Asia Regional Chengdu Online

[align=left]Recommend[/align]
liuyiding | We have carefully selected several similar problems for you: 4297 4289 4290 4291 4292
ac代码
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: