您的位置:首页 > 其它

HDU 1036 Average is not Fast Enough!

2015-02-09 10:16 435 查看
[align=left]Problem Description[/align]
A relay is a race for two or more teams of runners. Each member of a team runs one section of the race. Your task is to help to evaluate the results of a relay race.

You have to process several teams. For each team you are given a list with the running times for every section of the race. You are to compute the average time per kilometer over the whole distance. That's easy, isn't it?

So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm participated e.g. at the "SOLA" relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after the contest is
over.

 

[align=left]Input[/align]
The first line of the input specifies the number of sections n followed by the total distance of the relay d in kilometers. You may safely assume that 1 <= n <= 20 and 0.0 < d < 200.0. Every following line gives information about
one team: the team number t (an integer, right-justified in a field of width 3) is followed by the n results for each section, separated by a single space. These running times are given in the format "h:mm:ss" with integer numbers for the hours, minutes and
seconds, respectively. In the special case of a runner being disqualified, the running time will be denoted by "-:--:--". Finally, the data on every line is terminated by a newline character. Input is terminated by EOF.

 

[align=left]Output[/align]
For each team output exactly one line giving the team's number t right aligned in a field of width 3, and the average time for this team rounded to whole seconds in the format "m:ss". If at least one of the team's runners has been
disqualified, output "-" instead. Adhere to the sample output for the exact format of presentation.

 

[align=left]Sample Input[/align]

2 12.5
5 0:23:21 0:25:01
42 0:23:32 -:--:--
7 0:33:20 0:41:35

 

[align=left]Sample Output[/align]

  5: 3:52 min/km
42: -
7: 6:00 min/km

 

[align=left]Source[/align]
University of Ulm Local Contest 2001

 
 
其实就是一个水题。
格式挺麻烦。
上个代码自然都懂了
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#include<iostream>
int main()
{
double n;
double l;
scanf("%lf%lf",&n,&l);
int i;
int p;
while(scanf("%d",&p)!=EOF)
{
char s[32][323];
double sum=0;
int flag=0;
for(i=1;i<=n;i++)
{
scanf("%s",s[i]);
if(s[i][0]=='-')
flag=1;
}
if(flag)
{
printf("%3d: -\n",p);
continue;
}
printf("%3d:",p);
for(i=1;i<=n;i++)
sum+=(s[i][0]-'0')*3600+((s[i][2]-'0')*10+(s[i][3]-'0'))*60+(s[i][5]-'0')*10+(s[i][6]-'0');
int x=sum/l;
if(sum/l-x>0.5)
x++;
printf(" %d:%02d min/km\n",x/60,x%60);
}
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM算法 amp c math.h printf