您的位置:首页 > 其它

HDOJ 题目2680Choose the best route(最短路)

2015-02-09 01:16 393 查看

Choose the best route

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8044 Accepted Submission(s): 2648



[align=left]Problem Description[/align]
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s
home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

[align=left]Input[/align]
There are several test cases.

Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands
for the bus station that near Kiki’s friend’s home.

Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .

Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

[align=left]Output[/align]
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

[align=left]Sample Input[/align]

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1


[align=left]Sample Output[/align]

1
-1


[align=left]Author[/align]
dandelion

[align=left]Source[/align]
2009浙江大学计算机研考复试(机试部分)——全真模拟

[align=left]Recommend[/align]
lcy | We have carefully selected several similar problems for you: 2722 2962 2433 2482 1482
多个起点,一个终点,反向见图,迪杰斯特拉瞬秒。
睡前水一道,睡
ac代码
#include<stdio.h>
#include<string.h>
#define INF 0xfffffff
int map[1010][1010],dis[1010],v[1010];
int n,m,u;
void init()
{
int i,j;
for(i=0;i<=n;i++)
for(j=0;j<=n;j++)
map[i][j]=INF;
}
void digs(int x)
{
int i,j;
memset(v,0,sizeof(v));
for(i=1;i<=n;i++)
dis[i]=map[x][i];
dis[x]=0;
v[x]=1;
for(i=1;i<=n;i++)
{
int min=INF;
int flag=-1;
for(j=1;j<=n;j++)
{
if(!v[j]&&dis[j]<min)
{
flag=j;
min=dis[j];
}
}
if(flag==-1)
break;
v[flag]=1;
for(j=1;j<=n;j++)
{
if(!v[j]&&dis[j]>dis[flag]+map[flag][j])
dis[j]=dis[flag]+map[flag][j];
}
}
}
int main()
{
while(scanf("%d%d%d",&n,&m,&u)!=EOF)
{
int i;
init();
for(i=0;i<m;i++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
if(c<map[b][a])
map[b][a]=c;
}
digs(u);
int num,ans=INF;
scanf("%d",&num);
while(num--)
{
int x;
scanf("%d",&x);
if(dis[x]<ans)
ans=dis[x];
}
if(ans!=INF)
printf("%d\n",ans);
else
printf("-1\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: