您的位置:首页 > 其它

HDU 5170 GTY's math problem

2015-02-08 15:55 369 查看
取对数比较就好了log(a^b )=b*log(a) ,注意会有精度误差...

GTY's math problem

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 456 Accepted Submission(s): 212



[align=left]Problem Description[/align]
GTY is a GodBull who will get an Au in NOI . To have more time to learn algorithm knowledge, he never does his math homework. His math teacher is very unhappy for that, but she can't do anything because GTY can always get a good mark
in math exams. One day, the math teacher asked GTY to answer a question. There are four numbers on the blackboard -
a,b,c,d
. The math teacher wants GTY to compare ab
with cd
. Because GTY never does his homework, he can't figure out this problem! If GTY can't answer this question correctly, he will have to do his homework. So help him!

[align=left]Input[/align]
Multi test cases (about 5000). Every case contains four integers a,b,c,d(1≤a,b,c,d≤1000
)separated by spaces. Please process to the end of file.

[align=left]Output[/align]
For each case , if ab>cd
, print '>'. if ab<cd
, print '<'. if ab=cd
, print '='.

[align=left]Sample Input[/align]

2 1 1 2
2 4 4 2
10 10 9 11


[align=left]Sample Output[/align]

>
=
<


AC代码;

#include "stack"
#include "cstdio"
#include "iostream"
#include "cmath"
#include "set"
#include "sstream"
#include "cctype"
#include "string"
#include "cstring"
#include "algorithm"
#include "queue"
#include "map"
using namespace std;
#define LL long long
#define inf 0x7ffffff
#define pa pair<int,int>
#define pi 3.1415926535897932384626433832795028841971

const int M=55;

int main()
{
double a,b,c,d;
while(cin>>a>>b>>c>>d)
{
double p,s1,s2;
p=log(a)/log(c);
b=p*b;
s1=b;s2=d;
if(s1-s2<0.00001&&s1-s2>-0.00001)
cout<<"=\n";
else if(s1<s2)
cout<<"<\n";
else
cout<<">\n";

}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: