您的位置:首页 > 其它

BestCoder Round #29 1001 GTY's math problem

2015-02-07 21:29 134 查看

GTY's math problem

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 0 Accepted Submission(s): 0



Problem Description

GTY is a GodBull who will get an Au in NOI . To have more time to learn algorithm knowledge, he never does his math homework. His math teacher is very unhappy for that, but she can't do anything because GTY can always get a good mark in math exams. One day, the math teacher asked GTY to answer a question. There are four numbers on the blackboard - a,b,c,d. The math teacher wants GTY to compare ab with cd. Because GTY never does his homework, he can't figure out this problem! If GTY can't answer this question correctly, he will have to do his homework. So help him!



Input

Multi test cases (about 5000). Every case contains four integers a,b,c,d(1≤a,b,c,d≤1000)separated by spaces. Please process to the end of file.



Output

For each case , if ab>cd , print '>'. if ab<cd , print '<'. if ab=cd , print '='.



Sample Input

2 1 1 2
2 4 4 2
10 10 9 11




Sample Output

>
=
<

题解思路:注意精度控制:
代码:
#include <set>
#include <map>
#include <cmath>
#include <time.h>
#include <queue>
#include <deque>
#include <stack>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
using namespace std;
#define Max(a,b) a>b?a:b
#define Min(a,b) a>b?b:a
#define mem(a,b) memset(a,b,sizeof(a))
int dir[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};
int main()
{
    int a,b,c,d;
    double ans1,ans2;
    while(scanf("%d %d %d %d",&a,&b,&c,&d) != -1)
    {
        ans1 = 1.0 * b * log10(a);
        ans2= 1.0 * d * log10(c);
        if(fabs(ans1 - ans2) < 1e-10)
            printf("=\n");
        else if(ans1 - ans2 > 1e-10)
            printf(">\n");
        else
            printf("<\n");
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: