您的位置:首页 > 其它

Uva 455-periodic strings

2015-02-07 14:34 309 查看
UVA - 455
Periodic Strings

Time Limit:3000MS Memory Limit:Unknown 64bit IO Format:%lld & %llu
SubmitStatus

Description




 Periodic Strings 
A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of lengthk. For example, the string "abcabcabcabc" has period 3, since it is formed by 4 repetitions of
the string "abc". It also has periods 6 (two repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive
input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1

HoHoHo

Sample Output

2


1.枚举字符串长度的约数i,判断是否为周期

2.若是,输出i;否则i++,继续判断

本题输出格式比较坑

#include <iostream>
#include <cstring>

using namespace std;

int period(int p, int n, char* a)
{                   //判断周期
for(int i = 0; i < n - p; i++)
{
if(a[i] != a[i+p])
return 0;          //不是周期,返回0
}
return p;
}
int main()
{
int num,first = 0;
char a[110];
cin >> num;
//接收回车符,防止被cin.getline读取
while(num--)
{
cin >> a;
int len = strlen(a), p = 0;
for(int i = 1; i <= len; i++)
{
if(len%i == 0)
{p = i;
if(period(p,len,a))
break;
}
}
if(first) cout << endl << p << endl;
else
{cout << p << endl;first =1;}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: