您的位置:首页 > 产品设计 > UI/UE

SDUT 1103 Quicksum

2015-02-07 13:02 232 查看

题目描述

A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document
contents, and in many other situations where it is necessary to detect undesirable changes in data.

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including
consecutive spaces.

A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example
Quicksum calculations for the packets "ACM" and "MID CENTRAL":

ACM: 1*1 + 2*3 + 3*13 = 46

MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

输入

The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.

输出

For each packet, output its Quicksum on a separate line in the output.

示例输入

ACM
MID CENTRAL
REGIONAL PROGRAMMING CONTEST
ACN
A C M
ABC
BBC
#


示例输出

46
650
4690
49
75
14
15


#include <stdio.h>

#include <string.h>

int main()

{

char s[300];
int a[300];

int i,sum;

while(gets(s),s[0]!='#')

{

sum=0;

for(i=0;i<strlen(s);i++)

{

if(s[i]=='A') a[i]=1;
if(s[i]=='B') a[i]=2;
if(s[i]=='C') a[i]=3;
if(s[i]=='D') a[i]=4;
if(s[i]=='E') a[i]=5;
if(s[i]=='F') a[i]=6;
if(s[i]=='G') a[i]=7;
if(s[i]=='H') a[i]=8;
if(s[i]=='I') a[i]=9;
if(s[i]=='J') a[i]=10;
if(s[i]=='K') a[i]=11;
if(s[i]=='L') a[i]=12;
if(s[i]=='M') a[i]=13;
if(s[i]=='N') a[i]=14;
if(s[i]=='O') a[i]=15;
if(s[i]=='P') a[i]=16;
if(s[i]=='Q') a[i]=17;
if(s[i]=='R') a[i]=18;
if(s[i]=='S') a[i]=19;
if(s[i]=='T') a[i]=20;
if(s[i]=='U') a[i]=21;
if(s[i]=='V') a[i]=22;
if(s[i]=='W') a[i]=23;
if(s[i]=='X') a[i]=24;
if(s[i]=='Y') a[i]=25;
if(s[i]=='Z') a[i]=26;
else if(s[i]==' ')
a[i]=0;

}

for(i=0;i<strlen(s);i++)

{

sum=sum+a[i]*(i+1);

}

printf("%d\n",sum);

}

return 0;

}

总感觉写麻烦了。。。但是又想不出来好的方法
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: