您的位置:首页 > 其它

杭电ACM 最小公倍数

2015-02-06 21:12 459 查看

Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the
number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1


Sample Output

105
10296


代码:

/*
*Copyright (c)2014,烟台大学计算机与控制工程学院
*All rights reserved.
*文件名称:test.cpp
*作    者:冷基栋
*完成日期:2015年2月6日
*版 本 号:v1.0
*问题描述:找最小公倍数(两个输的最小公倍数、最大公约数、两数之积除以最大公约数)
*程序输入:一个整数n,和n组数
*程序输出:各组数的最小公倍数
*/
#include<iostream>
using namespace std;
long long gcd(long long a,long long b)
{
    return (a%b!=0?(gcd(b,a%b)):b);
}
long long lcm( long long u,long long v)
{
    long long h;
    h=gcd(u,v);
    return(u*v/h);//此处为了避免溢出可以先除再乘
}
long long a[100000];
int main()
{
    long long t,n,temp,i;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(i=0; i<n; i++)
            cin>>a[i];
        temp=a[0];
        for(i=1; i<n; i++)
        {
            temp=lcm(temp,a[i]);
        }
        cout<<temp<<endl;
    }
    return 0;
}

运行结果:



知识点总结:

数学方法 自定义函数的合理使用

学习心得:

好好学习 天天向上


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: