您的位置:首页 > 运维架构

HDOJ 题目4405 Aeroplane chess(概率dp求期望)

2015-02-06 18:26 369 查看

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1834 Accepted Submission(s): 1223



[align=left]Problem Description[/align]
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are
1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is
no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.

[align=left]Input[/align]
There are multiple test cases.

Each test case contains several lines.

The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).

Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).

The input end with N=0, M=0.

[align=left]Output[/align]
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.

[align=left]Sample Input[/align]

2 0
8 3
2 4
4 5
7 8
0 0


[align=left]Sample Output[/align]

1.1667
2.3441


[align=left]Source[/align]
2012 ACM/ICPC Asia Regional Jinhua Online

[align=left]Recommend[/align]
zhoujiaqi2010 | We have carefully selected several similar problems for you: 5169 5168 5167 5166 5165
题目大意:飞行棋,从0到n,置骰子,置到几就往前走几步,前进中会有捷径,比如2和5连到一起了,那你走到2时可以直接跳到5,如果5和8连到一起了,那你还可以继续跳到8,最后问跳到n时平均置几次骰子,也就是求期望。
ac代码
#include<stdio.h>
#include<string.h>
int link[100005];
double dp[100005];
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF,n||m)
{
int i,j;
memset(dp,0,sizeof(dp));
memset(link,-1,sizeof(link));
while(m--)
{
int a,b;
scanf("%d%d",&a,&b);
link[a]=b;
}
for(i=n-1;i>=0;i--)
{
if(link[i]!=-1)
{
dp[i]=dp[link[i]];
}
else
{
for(j=1;j<=6;j++)
{
if(i+j<=n)
{
dp[i]+=1.0/6*dp[j+i];
}
else
break;
}
dp[i]+=1;
}
}
printf("%.4lf\n",dp[0]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: