您的位置:首页 > 其它

poj 2503 Babelfish

2015-02-05 20:35 381 查看
Babelfish

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 34169Accepted: 14666
Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears
more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".
Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output
cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

题意:
给出字典的英文与外语的对照,然后给出外语,输出英语
题解:
裸的字典树

代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int Max=27;
const int maxn=811000;
struct node
{
int sign;
char str[20];
int next[Max];
}a[maxn];
int cur=0;
void insert(char *s,char *t)
{
int len,ans;
int p=0;
len=strlen(s);
for(int i=0;i<len;i++)
{
ans=s[i]-'a';
if(a[p].next[ans]!=0)
{
p=a[p].next[ans];
}
else
{
a[p].next[ans]=++cur;
a[cur].sign=0;
p=a[p].next[ans];
}
}
strcpy(a[p].str,t);
a[p].sign=1;
}
void find(char *s)
{
int len,ans;
int p=0;
len=strlen(s);
for(int i=0;i<len;i++)
{
ans=s[i]-'a';
if(a[p].next[ans]==0)
{
printf("eh\n");
return;
}
p=a[p].next[ans];
}
if(a[p].sign)
printf("%s\n",a[p].str);
else
printf("eh\n");
}
int main()
{
char str[30];
while(gets(str)&&str[0])
{
int pos=0;
while(str[pos++]!=' ');
str[pos-1]=0;
insert(str+pos,str);
}
while(gets(str))
find(str);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: