您的位置:首页 > 产品设计 > UI/UE

hdu 1005——Number Sequence

2015-02-04 22:36 375 查看
水题。但并不容易我是看题解才知道周期的,我也知道有周期可求不出来!!!!!

大神物语:凡是给出运算公式的数学题,只要没有优化的话,超时超内存是避免不了的!

如果直接根据式子写出for循环,则会爆栈。所以自己要根据给的式子找周期,该题明显是找规律的题,找它的运算周期;由关系式可知每一项只与它的前两项有关,

所以当连续的两项在前面出现过,则循环节出现。

对于公式f
=a*f[n-1]+b*f[n-2];后者只有7*7=49种可能。

为什么这么说,因为对于f[n-1]或f[n-2]的取值只有0,1,2,3,4,5,6,7种可能

又因为a,b固定,所以前后相乘产生49种可能。

一组测试数据中最坏的情况是49种情况都遇到,那么会在第50次运算中产生循环节

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 115443    Accepted Submission(s): 28057


[align=left]Problem Description[/align]
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

[align=left]Input[/align]
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

[align=left]Output[/align]
For each test case, print the value of f(n) on a single line.

 

[align=left]Sample Input[/align]

1 1 3
1 2 10
0 0 0

 

[align=left]Sample Output[/align]

2
5

#include<stdio.h>
int main()
{
int a,b,n,m,t;
int f[1010]={0,1,1};

while(scanf("%d%d%d",&a,&b,&n),a,b,n)
{
for(int i=3;i<49;i++)
f[i]=(a*f[i-1]+b*f[i-2])%7;
printf("%d\n",f[n%49]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: