您的位置:首页 > 产品设计 > UI/UE

HDOJ 题目2187 A sequence of numbers(快速幂水)

2015-02-04 22:05 302 查看

A sequence of numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3750 Accepted Submission(s): 1150



[align=left]Problem Description[/align]
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know
some numbers in these sequences, and he needs your help.

[align=left]Input[/align]
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating
that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.

[align=left]Output[/align]
Output one line for each test case, that is, the K-th number module (%) 200907.

[align=left]Sample Input[/align]

2
1 2 3 5
1 2 4 5


[align=left]Sample Output[/align]

5
16


[align=left]Source[/align]
2009 Multi-University Training Contest 1 - Host by TJU

[align=left]Recommend[/align]
gaojie | We have carefully selected several similar problems for you: 2819 2825 2822 2821 2820
无聊,切道氺题压压惊。
题目大意:判断是等比还是等差,并求出第n项,等差直接算,等比快速幂算
ac代码
#include<stdio.h>
#include<string.h>
#define mod 200907
__int64 qpow(__int64 a,__int64 b)
{
__int64 ans=1;
while(b)
{
if(b&1)
ans=(ans*a)%mod;
a=(a*a)%mod;
b/=2;
}
return ans;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
__int64 a,b,c,d;
scanf("%I64d%I64d%I64d%I64d",&a,&b,&c,&d);
if(c-b==b-a)
{
printf("%I64d\n",(a+((d-1)*(c-b))%mod)%mod);
}
else
{
printf("%I64d\n",(a*(qpow(b/a,d-1))%mod)%mod);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: